Intermittent Error When Clicking Unsubscribe Links
Incident Report for SendGrid
Resolved
Our engineering team determined that unsubscribes began to intermittently fail when clicking on unsubscribe links beginning at approximately 5:10 AM PDT on October 24th, 2023. After investigating this issue further, the resulting error when links failed would include "invalid unsubscribe request" on an otherwise properly formatted unsubscribe link. Due to the nature of the issue, not all unsubscribe links during the affected period failed but instead the occurring issue intermittently affected links. On October 26th at approximately 9:30 AM PDT, the engineering team deployed code to resolve the intermittently failing unsubscribe links. Valid unsubscribe links previously failing have since been reported as resolving properly. This issue did not affect mail send. Systems are now operating normally at this time. Thank you for your patience while this issue was being resolved.
Posted Oct 27, 2023 - 14:08 PDT
Update
Engineers are still monitoring the issue with the Unsubscribe Links, no new reports have been received and some of these have been reported as fixed. Our team will continue to monitor this issue. We will follow up within 12 hours, or as more information is available.
Posted Oct 27, 2023 - 03:48 PDT
Update
Engineers are still monitoring the issue with the Unsubscribe Links, no new reports have been received and some of these have been reported as fixed. Our team will continue to monitor this issue. We will follow up within 24 hours, or as more information is available.
Posted Oct 26, 2023 - 12:34 PDT
Monitoring
Engineers are still investigating the issue with the Unsubscribe Links, no new reports have been received and some of these have been reported as fixed. Our team will continue to monitor this issue. We will follow up in 1 more hour, or as more information is available.
Posted Oct 26, 2023 - 11:32 PDT
Update
Our engineers are continuing to investigate this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 26, 2023 - 11:14 PDT
Investigating
Starting around 9:36AM PDT on October 26th, 2023, our engineers began investigating an issue with intermittent errors returned when clicking unsubscribe links in emails. This issue is affecting unsubscribe links in emails. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 26, 2023 - 10:12 PDT
This incident affected: Email Activity.