Delayed Suppressions Information
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed that all delayed suppressions data is now posted to the system as expected. All services are now operating normally at this time.
Posted Nov 21, 2022 - 18:33 PST
Monitoring
Our engineers have confirmed that the suppressions data is now posted as expected and suppressions delays related to this incident are resolved. Our team will continue monitoring the stability of the affected system for the next 30 minutes for any further anomalies. We will provide another update in 30 minutes or as soon as more updates are available.
Posted Nov 21, 2022 - 18:13 PST
Update
The SendGrid system responsible for dequeuing suppressions data is continuing to stabilize but delays will be present until the system is back to normal operation. Suppressions will continue to potentially be delayed for up to 30 to 40 minutes from when an affected suppression was originally recorded. Another update will be provided in the next two hours or as soon as more information is available.
Posted Nov 21, 2022 - 17:03 PST
Update
Our engineering team confirmed that delayed suppressions data is dequeuing from the affected SendGrid system. Suppressions will continue to be delayed for up to 30 to 40 minutes from when an affected suppression was originally recorded. Delays are expected to continue until we confirm this incident to be in a monitoring state. Delay time and impact will vary between different SendGrid accounts. Another update will be provided in the next hour or as soon as more information is available.
Posted Nov 21, 2022 - 16:05 PST
Identified
Beginning 2:11 PM Pacific Time, our engineers determined that new suppression information is being delayed before getting posted to the SendGrid system. This includes delays retrieving suppression information in the user interface along with using the SendGrid Suppressions API. This does not affect mail send. Another update will be provided in the next hour or as soon as more information is available.
Posted Nov 21, 2022 - 15:37 PST
This incident affected: Statistics.