Missing Category Stats between July 25th and July 30th
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the missing category statistics have been properly and accurately restored. All statistics are now displaying normally at this time.
Posted Aug 20, 2024 - 16:11 PDT
Monitoring
Our engineers confirmed that the deployed fix to restore any missing category stats between the dates of July 25th and July 30th is complete. We will monitor the results of this deploy over the next 30 minutes to ensure proper restoration of missing category statistics for the period at which point another update will be given.
Posted Aug 20, 2024 - 15:41 PDT
Update
Our engineers have identified the work needed to restore missing category stats between the dates of July 25th and July 30th. The work needed to complete restoration during this period is anticipated to require several hours for the internal SendGrid system to properly backfill the missing statistics. Once the data is fully and accurately backfilled for the period, another update will be provided via this status post. Thank you for your patience.
Posted Aug 20, 2024 - 13:26 PDT
Update
Our engineers are continuing to work towards a fix for missing category stats from the dates of July 25th to July 30th. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 20, 2024 - 12:33 PDT
Update
Our engineers are continuing to work towards a fix for missing category stats from the dates of July 25th to July 30th. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 20, 2024 - 11:29 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 20, 2024 - 10:30 PDT
Investigating
Starting around 10:12 AM Pacific Time on August 20th, our engineers began investigating an issue with category stats. Users may have experienced missing category stats data via API and UI from the dates of July 25th to July 30th. This does not impact mail send. We will provide another update in one hour or as soon as more information becomes available.
Posted Aug 20, 2024 - 10:26 PDT
This incident affected: Statistics.