SendGrid Plan Changes Unavailable and Payment Errors
Incident Report for SendGrid
Resolved
The billing functionality has been confirmed as properly restored to the SendGrid platform. Restoration of the SendGrid billing functionality took place at approximately 1:30 PM PDT. All services are now operating normally at this time.
Posted Jul 31, 2024 - 15:43 PDT
Update
In reviewing the stability of the SendGrid platform billing functionality, our team determined that the billing system is showing signs of significant improvement. However, the stability of the system will continue to be monitored until this issue is confirmed to be resolved. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 31, 2024 - 14:44 PDT
Monitoring
As of 1:27 PM PDT, the third party involved in this incident has notified that a deployment has been made and it was stated that there is a noted recovery in performance to the billing functionality of downstream impacted systems (Twilio SendGrid). While this recovery should include the SendGrid platform and its billing function, we will continue to investigate the functionality of the SendGrid platform specifically as it relates to provider changes. Until this issue is confirmed as resolved, please be aware that there may still be degraded and intermittent inabilities to change plans (upgrade or downgrade), process a payment or make other billing-related changes within the SendGrid user interface. This incident does not directly impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 31, 2024 - 13:45 PDT
Identified
Due to a third party provider incident, the SendGrid platform is experiencing an issue in billing functionality as of 12:03 PM PDT. Users may experience inability to upgrade or downgrade plans, and cannot access the billing page via the user interface. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 31, 2024 - 12:50 PDT
This incident affected: Billing.