Failures to Process Payments, Change Plans or Update Payment Details
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with payment processing has been resolved. All services are now operating normally at this time.
Posted Aug 04, 2022 - 07:57 PDT
Monitoring
Previous payments that were delayed are now gradually processing. However, a subset of customers may still experience delays in payment processing, along with changes to plans or updating of billing details. Our team advises allowing up to 24 hours for automated processing of any delayed payments or for manual retries. Our engineers will continue to monitor the performance of our system and provide an update within the next 24 hours or as soon as more information is available.
Posted Aug 03, 2022 - 18:10 PDT
Identified
Our engineers have identified the current billing issues associated to third party providers. A subset of customers may experience delays in seeing payment or plan upgrades process. There may also be errors when updating the payment method, and when trying to process any previous payments. Mail send is not affected at this time. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 03, 2022 - 16:55 PDT
Investigating
Starting around 4:00 PM PST on August 3rd, 2022, our team began investigating billing issues. Customers may experience delays in seeing their payments or plan upgrades processed. Mail send is not affected at this time. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 03, 2022 - 16:21 PDT
This incident affected: Billing.