Global Statistics Delayed
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with delays in Global Statistics has been resolved. All services are now operating normally at this time.
Posted Aug 03, 2023 - 19:29 PDT
Update
Our engineers have monitored the fix and confirmed the issue with delays in Global Statistics has been resolved. All services are now operating normally at this time.
Posted Aug 03, 2023 - 16:30 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 03, 2023 - 15:58 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 03, 2023 - 15:44 PDT
Investigating
Starting around 3:34pm PT on August 3rd, our engineers began investigating an issue with delays in our Global Statistics. Users may experience delays retrieving Global Statistics within their user interface and via API. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 03, 2023 - 15:40 PDT
This incident affected: Statistics.