Our engineers are continuing to monitor system performance. We will provide another update in two hours or as soon as new information becomes available.
Posted Mar 19, 2025 - 13:02 PDT
Monitoring
At 11:25 AM PT, our engineers implemented a fix and are now monitoring system performance to ensure impacted endpoints no longer exhibit issues. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 19, 2025 - 11:56 PDT
Update
Our engineers are continuing to work towards a fix. We will provide another update in two hours or as soon as more information becomes available.
Posted Mar 19, 2025 - 11:19 PDT
Identified
Our engineers have identified the issue and are working towards a fix with impacted endpoints. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 19, 2025 - 10:20 PDT
Investigating
Starting around 8:05 PT on March 19th, our engineers began investigating an issue with Deliverability Insights endpoints experiencing high latency and errors, as well as the /v3/suppressions/bounce/classifications endpoint. We will provide another update in an hour or as soon as more information becomes available.