SendGrid - Subset to email services experiencing 5xx errors

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed all services are now operating normally.
Posted May 12, 2026 - 17:22 PDT

Monitoring

Between 16:10 PDT and 16:27 PDT on 05/12/2026, our engineers began investigating an issue with a subset of services experiencing 5xx errors. Users may have experienced issues when accessing subusers, authenticating domains and link branding records, accessing the account, and checking account stats.

This does not impact mail send. 

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in an hour or as soon as more information becomes available.
Posted May 12, 2026 - 16:48 PDT
This incident affected: Website and Statistics.