Service Disruption: Signups, Upgrades, Downgrades, and Account Management Functions
Incident Report for SendGrid
Resolved
We have verified that the fix put in place is working as expected. Our systems are now fully operational. If you are still experiencing issues with your account, please try again at this time. We greatly appreciate your patience and apologize for any inconvenience this may have caused. If you have any questions, you can reach out to our Support team at https://support.sendgrid.com.
Posted 3 months ago. Jul 30, 2019 - 19:04 PDT
Monitoring
Starting around 6PM MT, our team began investigating issues regarding signups, upgrades, downgrades, and other account management functions relating to subusers, teammates, and IPs. We’ve implemented a fix and are currently monitoring its performance. We apologize for the inconvenience this may have caused and thank you for your patience. If you have any questions, please contact our Support team at https://support.sendgrid.com/
Posted 3 months ago. Jul 30, 2019 - 18:48 PDT
This incident affected: Website.