Service Disruption: Dashboard Display Issues and Stats API Timeouts
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 11:43 PDT
Update
We have monitored the fix and confirmed the issue has been resolved. We greatly appreciate your patience and apologize for any inconvenience this may have caused. Please contact our Support team with any questions at https://support.sendgrid.com/.
Posted Jul 01, 2020 - 08:55 PDT
Monitoring
Our engineers identified the issue and implemented a fix. We are currently monitoring the situation and will provide updates. We apologize for any inconvenience this may have caused. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 01, 2020 - 08:35 PDT
Investigating
We are currently investigating stats dashboard display issues and stats API timeouts. Mail send is not impacted. We sincerely apologize for the inconvenience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 01, 2020 - 08:10 PDT
This incident affected: Other Services (API) and Website.