Email Billing functionality degraded
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with Billing functionality has been resolved. All services are now operating normally at this time.
Posted Oct 23, 2023 - 08:45 PDT
Monitoring
Mitigation measures have been applied. Performance functionality is back to normal at this time
Posted Oct 23, 2023 - 07:49 PDT
Investigating
Starting at 06:01 PDT on October 23, 2023, our engineers were alerted about an issue with SendGrid Billing updates, This issue is affecting account upgrades, request of invoices and payment functionality. This incident does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 23, 2023 - 07:36 PDT
This incident affected: Billing.