Intermittent Failed Subuser Creation
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with creating subusers has been resolved. Subusers that previously failed to create have been retried by our systems and recreated. All services are now operating normally at this time.
Posted Sep 28, 2023 - 10:42 PDT
Update
Our teams are still monitoring the fix that was implemented. Engineers are also working on retrying subusers that previously failed to create. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 28, 2023 - 10:21 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Users should no longer see subusers fail to create. Subusers that previously failed to create will be retried by our systems. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 28, 2023 - 09:21 PDT
Update
Our engineers have implemented a fix and are monitoring system performance. Users should no longer see subusers fail to create. Subusers that previously failed to create will be retried by our systems. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 28, 2023 - 09:21 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 28, 2023 - 09:10 PDT
Investigating
Beginning at 7:44 AM PT, our Engineers began investigating an issue with subuser creation. At this time, customers may see subusers fail to create via the API even when receiving a 2xx level response from the API. We will provide another update on this issue within an hour or as soon as more information is available.
Posted Sep 28, 2023 - 08:38 PDT
This incident affected: API.