Marketing Campaigns Signup Form Errors
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Mar 30, 2021 - 21:13 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. Marketing Campaigns Signup Forms should now be working again. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 30, 2021 - 20:46 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 30, 2021 - 20:17 PDT
Investigating
Starting around 4PM PT on 3/30/21, our engineers began investigating an issue with the Marketing Campaign Signup Forms. Customers may experience intermittent errors when trying to submit Marketing Campaign Signup Forms. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 30, 2021 - 20:01 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).