Service Disruption: New Account Signup
Incident Report for SendGrid
Resolved
Issues with new account signup and sub-user account creation have been resolved. If you were unable to create a new account or a sub-user account during this timeframe, please retry creation with a different username from the previous attempt. We greatly appreciate your patience through this process and apologize for any inconvenience this may have caused. Please contact our Support team with any questions at https://support.sendgrid.com/.
Posted 8 months ago. Feb 15, 2019 - 12:46 PST
Monitoring
Our Operations teams have identified the source of the issue and implemented a fix for new account signup and sub-user account creation. If you were unable to create a new account or a sub-user account during this timeframe, please create a new account or new sub-user with a different username from the prior attempt. We are continuing to monitor the situation and will provide an update when we confirm the issue has been resolved. We apologize for any inconvenience this may have caused and greatly appreciate your patience. Please reach out to our Support team with any questions at https://support.sendgrid.com/
Posted 8 months ago. Feb 15, 2019 - 12:23 PST
Update
Our Operations teams are continuing to investigate intermittent issues with paid and free account signup and sub-user account creation and have no new information to provide at this time. As new information becomes available, we will provide further updates. We greatly appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 8 months ago. Feb 15, 2019 - 11:42 PST
Update
Our Operations teams are continuing to investigate intermittent issues with paid and free account signup and sub-user account creation. As further information becomes available, we will provide updates. We greatly appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 8 months ago. Feb 15, 2019 - 10:33 PST
Update
Our Operations teams continue investigating issues with free and paid account signup. Additionally, sub-user account creation appears to be impacted by this issue. As more information becomes available, we will continue to provide updates. We apologize for any inconvenience this may be causing and appreciate your patience. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 8 months ago. Feb 15, 2019 - 09:55 PST
Update
Our Operations teams continue to investigate issues with free and paid account signup at this time. As more information becomes available, we will provide an update. We apologize for any inconvenience this may be causing and appreciate your patience. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted 8 months ago. Feb 15, 2019 - 09:25 PST
Investigating
We are currently investigating issues with free and paid new account signups. Once we have more information we will provide it. We appreciate your patience and apologize for any inconvenience this may be causing.
Posted 8 months ago. Feb 15, 2019 - 08:40 PST
This incident affected: Other Services (API) and Website.