Technical Incident : Mail Settings Propagation Delays
Incident Report for SendGrid
Resolved
Our engineers have confirmed that the issue has been resolved. We thank you for your patience and apologize for any inconvenience this may have caused.
Posted Nov 06, 2020 - 20:41 PST
Update
We are still monitoring our systems and will provide updates as they become available. Thank you for your continued patience.
Posted Nov 06, 2020 - 19:52 PST
Update
We are continuing to monitor the situation. We appreciate your patience.
Posted Nov 06, 2020 - 18:02 PST
Update
We are continuing to monitor the situation. We appreciate your patience.
Posted Nov 06, 2020 - 16:33 PST
Update
We are still monitoring our systems and will provide updates as they become available. Thank you for your continued patience. We apologize for any inconvenience this may cause.
Posted Nov 06, 2020 - 15:02 PST
Update
We are still monitoring our systems and will provide updates as they become available. Thank you for your continued patience.
Posted Nov 06, 2020 - 13:27 PST
Update
We are still monitoring our systems and will provide an update when we confirm the issue has been resolved. We appreciate your patience and apologize for any inconvenience this may be causing.
Posted Nov 06, 2020 - 11:48 PST
Monitoring
Our engineers have implemented a fix and are now monitoring its performance. We will continue to provide updates. We appreciate your patience.
Posted Nov 06, 2020 - 10:27 PST
Identified
Our engineering team has identified the issue and is working towards a fix. Thank you for your patience.
Posted Nov 06, 2020 - 10:08 PST
Investigating
As of 3.00am MT, our engineers have determined that a subset of customers may see intermittent delays when changing mail settings. At this time mail flow is not impacted, however if users have updated their settings during this time, mail will still be sent with the old settings. Our engineers are investigating and will provide updates as they become available. We apologize for any inconvenience this may cause.
Posted Nov 06, 2020 - 09:05 PST
This incident affected: Other Services (API) and Website.