Unable to Create Support Ticket from SendGrid Help Center

Incident Report for SendGrid

Update

We are continuing to monitor for any issues. We will provide another update in an hour or as soon as more information becomes available.
Posted Feb 11, 2026 - 10:43 PST

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Customer should be able to submit a support ticket through the SendGrid Help Center now. We will provide another update in an hour or as soon as more information becomes available.
Posted Feb 11, 2026 - 09:37 PST

Investigating

Starting around 8:15 am PST on February 11th, our engineers began investigating an issue with the SendGrid Help Center and the Ticket Creation process. Customer may experience errors when creating a support ticket request within the SendGrid Help Center. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Feb 11, 2026 - 08:52 PST