Gmail Delivery Latency

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with email delivery to Gmail recipients has been resolved. All services are now operating normally at this time.
Posted Jan 24, 2026 - 19:00 PST

Update

We are observing that email delivery to Gmail recipients is recovering. However, we will continue to monitor the situation closely and await Google’s next official update. Additional updates will be shared as more information becomes available.
Posted Jan 24, 2026 - 12:43 PST

Monitoring

Gmail has confirmed that their services are currently affected, so we are continuing to monitor the situation closely while awaiting their next official update. We will provide another update as soon as more information becomes available.
Posted Jan 24, 2026 - 08:58 PST

Investigating

Starting around 1:00 PM UTC on January 24, 2026, our engineers began investigating an issue with email delivery to Gmail recipients.

Users may experience delivery delays, with emails taking up to 5x longer than usual to reach Gmail addresses. This is due to an issue on the Gmail/Google side, as other email providers remain unaffected.

This does not impact mail send; Emails are successfully delivered to Gmail's mail servers; however, Gmail is experiencing delays in delivering those messages to recipient inboxes. You can monitor the status of Google services via the official Google Status Page: https://www.google.com/appsstatus/dashboard/

We will provide another update as soon as more information becomes available.
Posted Jan 24, 2026 - 08:42 PST