Advance Stats Data Delay

Incident Report for SendGrid

Update

Our engineering team is actively investigating this issue and we will provide another update in one hour or as soon as more information becomes available.
Posted Feb 02, 2026 - 12:30 PST

Investigating

Starting around 11:00 AM PST, February 2nd, 2026, our engineers began investigating an issue affecting Advanced stats.

Our engineers have identified that a processing delay prevented about two hours of Advanced Stats data from January 27, 2026 from being included. As a result, customers may see incomplete Advanced Stats results when querying reports that include that time window. The Advanced Stats API remains available, but the data returned may be missing information for that period. This is currently being investigated and our team is working on a fix.

Email sending is not affected.

We’ll share another update within the next hour, or sooner as we learn more.
Posted Feb 02, 2026 - 11:29 PST
This incident affects: API and Statistics.