Issues With Login on Console and Email Sending

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with the SendGrid Console, as well as Mail Send and Marketing Campaigns, has been resolved. All services are now operating normally at this time.
Posted Oct 16, 2025 - 10:04 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Marketing Campaigns have de-queued and are currently being delivered. Customers should no longer be experiencing issues. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 16, 2025 - 09:54 PDT

Identified

Engineering has identified the root cause for issues affecting customer logins to the SendGrid Console, API email sending, and Marketing Campaigns. Our team is working through mitigation actions. We’ll provide another update within 15 minutes or as soon as new information becomes available.
Posted Oct 16, 2025 - 09:43 PDT

Update

We continue investigating issues affecting customer logins to the SendGrid Console. Some customers may also experience errors when sending emails via the API. Customers sending legacy marketing campaigns may have had a delay in sending out. We are seeing campaigns be sent now, but may be delayed. Our team is actively working to resolve the issue, and we’ll provide another update within 30 minutes or as soon as new information becomes available.
Posted Oct 16, 2025 - 09:35 PDT

Investigating

We’re currently investigating issues affecting customer logins to the SendGrid Console. Some customers may also experience errors when sending emails via the API. Our team is actively working to resolve the issue, and we’ll provide another update within 15 minutes or as soon as new information becomes available.
Posted Oct 16, 2025 - 09:21 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns), Mail Sending (API v3, API v2), and Website.