reCAPTCHA in Sign up forms for Marketing showing "Invalid domain for site key" error
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with the sign-up forms has been resolved. All services are now operating normally at this time.
Posted 20 days ago. Jan 15, 2025 - 17:09 PST
Update
Our engineers have identified the issue and are working toward a fix. The new forms and some forms created before the incident should be already functional, we estimate that in about 2 hours all forms will be functional again. We will provide another update as soon as more information becomes available.
Posted 20 days ago. Jan 15, 2025 - 14:34 PST
Update
Our engineers have identified the issue and are working toward a fix. We are still working toward a fix for existing signup forms. New signup forms are now working. We will provide another update in 2 hours or as soon as more information becomes available.
Posted 21 days ago. Jan 14, 2025 - 12:13 PST
Identified
Starting around 11:58 AM PT on January 13th, our engineers began investigating an issue with reCAPTCHA displaying an "Invalid domain for site key" error on New Marketing Campaigns Signup Forms. Due to this issue, end users of the forms are currently unable to submit form entries. This does not impact mail send. We've identified the cause, and we're actively working on a fix. We will provide another update as soon as more information becomes available.
Posted 21 days ago. Jan 14, 2025 - 08:29 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).