Page loops to 'Billing' tab when 'Your Products' is clicked on SendGrid Console
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with "YOUR PRODUCTS" tab being redirected to Billing tab has been resolved. All services are now operating normally at this time.
Posted Jul 27, 2023 - 08:57 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. The "YOUR PRODUCTS" page is working again when clicking on it, following the path: Settings > Account details > Your products. We will provide another update in an hour or as soon as more information becomes available.
Posted Jul 27, 2023 - 07:56 PDT
Update
Our engineers have identified the issue and are working toward a fix. We will provide another update in an hour or as soon as more information becomes available.
Posted Jul 27, 2023 - 07:19 PDT
Identified
Beginning at 05:00 AM PT on July 27, our engineers began investigating an issue with customers clicking on "YOUR PRODUCTS" tab being redirected to Billing tab instead. Customers may not be seeing any specific errors, just loading the wrong settings page. As a workaround, please access the link directly: https://app.sendgrid.com/account/products. This does not impact mail send. We will provide another update within an hour or as soon as more information becomes available.
Posted Jul 27, 2023 - 06:18 PDT
This incident affected: Website.