Stats undercounted for August 4th and 9th
Incident Report for SendGrid
Resolved
We have identified the impacted customers and the reason for the data discrepancy.
This is not an ongoing issue and we have confirmed that this was an isolated incident where stats on August 4, 2022 and August 9, 2022 were impacted. Our team has crafted a solution to restore the stats and is actively implementing the solution. The stats recovery is expected to take 2-4 weeks. In the meantime, please feel free to contact our support team at support@sendgrid.com should you have any additional questions
Posted Aug 31, 2022 - 17:40 PDT
Update
Our engineers are continuing to work towards the most optimal solution for data recovery. Customers may still see incorrect stats displayed for August 4, 2022 and August 9, 2022. We will provide another update within 24 hours or sooner if more information becomes available.
Posted Aug 31, 2022 - 09:34 PDT
Update
We are still evaluating the most optimal solution for data recovery. We'll provide another update in 24 hours or as soon as more information becomes available.
Posted Aug 30, 2022 - 10:17 PDT
Identified
On August 29th at around 10:40 am PT our teams noticed that the stats for August 4th and 9th were being undercounted. For those dates, this affected global stats specifically geographical, browser, devices, clients, and mailbox provider stats for a subset of customers. The issue has been identified, and the team is working towards a fix. Customers may experience issues with stats from mentioned dates. This does not impact mail send. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Aug 29, 2022 - 10:50 PDT
This incident affected: Statistics.