Email sending "Internal Server Error"
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. All services are now operating normally at this time.
Posted Jul 21, 2024 - 22:56 PDT
Update
Our engineering team has implemented a fix and is continuing to monitor the issue.
Posted Jul 21, 2024 - 22:06 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 21, 2024 - 21:10 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 21, 2024 - 21:09 PDT
Investigating
Starting around 8 PM PDT on July 21th, our engineers began investigating an issue with email sending. Users may experience delays in email sends. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 21, 2024 - 20:51 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP).