API Connection Errors, Mail Send and Stat Delays, and Site Unavailability
Incident Report for SendGrid
Resolved
Our engineers have monitored all impacted services and confirmed all issues have been resolved. All services are now operating normally at this time.
Posted May 06, 2021 - 20:52 PDT
Update
Our engineers are still monitoring system performance. We will provide another update in an hour or as soon as more information becomes available.
Posted May 06, 2021 - 19:42 PDT
Monitoring
Our engineers have implemented fixes for impacted services and are monitoring system performance. Site and API connectivity have been restored along with normal functionality for Marketing Campaigns. We will provide another update in an hour or as soon as more information becomes available.
Posted May 06, 2021 - 18:28 PDT
Identified
Our engineers have identified the issue and are working on implementing a fix. Customers may continue to experience intermittent API connection issues, site unavailability, and problems with Marketing Campaigns. Stats and event webhook posts should now be restored. We will provide updates in the next hour or sooner as they become available.
Posted May 06, 2021 - 17:42 PDT
Investigating
Starting around 4:45pm PT, our engineers began investigating an issue with API connection errors, mail send delays, and site unavailability. Customers may be experiencing intermittent API connection issues and notice mail send delays, including Marketing Campaigns. Stats and event webhook posts may also be delayed. Also, customers may have difficulty accessing our site at app.sendgrid.com. We will provide updates in the next hour or sooner as they become available.
Posted May 06, 2021 - 17:23 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns), Webhooks (Event Webhook, Parse API), and API, Website, Statistics, Email Activity, Partners, Billing.