Single Send Stats Delayed

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with single send stats has been resolved. All services are now operating normally at this time.
Posted Jan 05, 2026 - 06:44 PST

Monitoring

Our engineers have implemented a fix and are monitoring system performance. Single send stats are populating without a delay again. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 05, 2026 - 05:23 PST

Identified

Our engineers have identified the issue and are currently implementing a fix.
Posted Jan 05, 2026 - 04:58 PST

Investigating

As of 05/01 at 1:45 AM (PST), our engineering team has identified an issue affecting SendGrid Marketing (Single Send) statistics. Impacted customers may experience delays in statistics being populated. We will provide an update within the next hour or sooner as additional information becomes available.
Posted Jan 05, 2026 - 04:12 PST
This incident affected: Statistics.