Incident: Mail Delays
Incident Report for SendGrid
Resolved
The source of the disruption has been fixed and mail is now caught up. We sincerely apologize for any inconvenience this issue may have caused and greatly appreciate your patience and understanding in this. Please contact our Support team at https://support.sendgrid.com with any questions.
Posted 3 months ago. Jun 28, 2019 - 11:36 PDT
Monitoring
A small subset of our customers may have experienced mail delays. Our Operations team has investigated and implemented a fix. We are currently monitoring to ensure the issue is fixed. We apologize for any inconvenience this may be causing and will provide updates as they become available. Please contact our Support team https://support.sendgrid.com/ with any questions.
Posted 3 months ago. Jun 28, 2019 - 10:30 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2).