Errors returned at SendGrid login page at attempted sign in
Incident Report for SendGrid
Resolved
Starting from 05.50AM PT 06/29/2024 to 09:22 AM PT 06/29/2024, we experienced an issue with the Twilio SendGrid login page.
Users had received errors when attempting to sign in at the login page and also experienced issues accessing certain v3 endpoints resulting in 500 errors. This had a minor impact on creation of mail send batch IDs.
This issue has been mitigated and resolved. All services are now operating normally at this time.
Posted Jun 29, 2024 - 09:22 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 29, 2024 - 07:30 PDT
Identified
Our engineers have identified the issue and are working toward a fix. Users may continue to receive intermittent errors when attempting to sign in at the login page. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 29, 2024 - 07:13 PDT
Investigating
Starting around 5:50 AM PT on June 29th, our engineers began investigating an issue with the Twilio SendGrid login page. Users may receive errors when attempting to sign in at the login page. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 29, 2024 - 06:23 PDT
This incident affected: Website.