Password Reset Link Expired Upon Delivery
Incident Report for SendGrid
Resolved
Our engineers have monitored the code deployment reversion and confirmed that previous problems with invalid SendGrid password reset tokens is now resolved. All services are now operating normally at this time.
Posted Dec 12, 2022 - 13:47 PST
Monitoring
Upon further investigation, our engineering team determined that at 11:30 A.M. PT on December 12, 2022, a code deployment unintentionally caused the known invalidation of password reset tokens for SendGrid password reset links. At 1:06 P.M. PT today, our team reverted the deploy that resulted in these issues. Reviewing the reverted deployment, these changes are confirmed to now allow for successful password reset links with valid tokens for SendGrid. This did not impact mail send. Our team will monitor the reverted changes for the next 30 minutes or provide further information as it becomes available.
Posted Dec 12, 2022 - 13:17 PST
Investigating
Starting around 11:55 A.M. PT on December 12, 2022, our engineers began investigating an issue with password reset links expiring upon delivery when requested through the password reset page in the browser. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 12, 2022 - 12:24 PST