Technical Incident - Mail and Stat Delays, v2/v3 API Call Errors, Site and Signups Down
Incident Report for SendGrid
Resolved
Our team has monitored our system and confirmed that the issue has been resolved. Delayed mail has been dequeued and all impacted services are up and running again. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 15:04 PDT
Update
We are continuing to monitor system performances. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 14:35 PDT
Update
We are continuing to monitor system performances. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 14:07 PDT
Update
We have recovered the remaining impacted services and are continuing to monitor system performances. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 13:38 PDT
Update
We have recovered the remaining impacted services and are currently monitoring system performances. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 13:07 PDT
Monitoring
We have recovered the remaining impacted services and are currently monitoring system performances. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 12:38 PDT
Update
We are confident we have identified the source of the issue and are continuing work to recover the remaining impacted services. We will provide another update in 30 minutes or sooner. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 12:07 PDT
Identified
We believe we have identified the source of the issue which has been affecting our services. Our team has tested the remediation steps and are now working toward recovering all remaining impacted services. We will provide another update in 30 minutes or sooner as they become available. We sincerely apologize for the inconvenience this has caused and thank you for your patience.
Posted Jul 28, 2020 - 11:40 PDT
Update
At this time, we are receiving and delivering mail as expected (NOT including Legacy or New Marketing Campaigns). Due to an issue in one of our data centers this morning, mail received from approximately 6:00AM MT - 6:15AM MT is still stuck in delivery. We are working to get those delayed messages delivered as quickly as possible. Customers may still see errors with non-mail send related API calls. Our app.sendgrid.com site and signup is still down. We sincerely apologize for the inconvenience and thank you for your patience. We will provide another update in 30 minutes or sooner as we get updates. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 11:15 PDT
Update
We are still seeing mail and stat delays (including Legacy and New Marketing Campaigns). Mail is being accepted but could be stuck in queue. Users may be experiencing a higher volume of v2/v3 API call errors, especially 5xx errors around 9:45 AM MT. Our app.sendgrid.com site and signups are still down. We sincerely apologize for the inconvenience and thank you for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 09:46 PDT
Update
We are still investigating issues around mail and stat delays (including Legacy and New Marketing Campaigns), v2/v3 API calls, unavailability of our app.sendgrid.com site, and signups. We will continue to provide updates as they become available. We thank you for your patience and sincerely apologize for any inconvenience this may be causing. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 08:00 PDT
Update
Customers may be experiencing issues with mail and stat delays (including Marketing Campaigns), v2/v3 API calls, unavailability of our app.sendgrid.com site, and signups. We are still investigating the issue and will provide updates as they become available. We sincerely apologize for any inconvenience this may cause. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 06:37 PDT
Investigating
Starting around 6AM MT, users may be experiencing issues regarding mail delays, v2/v3 API calls, and unavailability of our site. We are currently investigating and will provide updates as they become available. We sincerely apologize for the any inconvenience this may cause. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 05:53 PDT
This incident affected: Other Services (API), Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns), and Website.