Service Disruption - Rejecting Small Number of HTTP and SMTP Requests
Incident Report for SendGrid
Resolved
We’ve monitored our systems after implementing the fix and have confirmed that customer impact has been remediated. We thank you for your patience and offer our sincere apology.
Posted Dec 03, 2020 - 02:58 PST
Update
We believe all customer impact has been mitigated at this point and will continue monitoring system performance. We will update again in one hour, or less if more information becomes available. Thank you for your patience.
Posted Dec 03, 2020 - 01:49 PST
Monitoring
Our Engineers have implemented a fix and we are seeing the number of rejected HTTP and SMTP requests decreasing. We will continue to monitor the situation to make sure errors continue to trend downwards. We will update again in one hour or less and offer our sincerest apology for any inconvenience.
Posted Dec 03, 2020 - 01:05 PST
Identified
Our Engineering team has identified the issue and is working on implementing a fix. We will update again in one hour or less and offer our sincerest apology for any inconvenience.
Posted Dec 03, 2020 - 00:09 PST
Update
Investigation continues into the intermittent rejection of a small number of HTTP and SMTP requests. Customers may be experiencing 421 SMTP responses and 503 HTTP responses intermittently. We will update in one hour, or less if more information becomes available. We apologize for any inconvenience.
Posted Dec 02, 2020 - 23:31 PST
Update
Our engineers continue to investigate the intermittent rejection of a small number of HTTP and SMTP requests. Customers may be experiencing 421 SMTP responses and 503 HTTP responses. We will update in one hour, or less if more information becomes available. We apologize for any inconvenience caused.
Posted Dec 02, 2020 - 22:36 PST
Investigating
Our engineers are currently investigating the intermittent rejection of HTTP and SMTP requests. Customers may be experiencing intermittent 421 responses to SMTP requests and 503 responses to HTTP requests. We will update in one hour, or less if more information becomes available. We apologize for any inconvenience caused.
Posted Dec 02, 2020 - 21:32 PST
This incident affected: Mail Sending (API v3, SMTP, API v2) and Other Services (API).