Certificate Errors for Links in Google Chrome
Incident Report for SendGrid
Resolved
Our team re-issued the valid certificates associated with our SendGrid-hosted links. Links that previously showed the certificate error now will begin to resolve when using the re-issued links. For those still encountering the link certificate errors, please update your Google Chrome browser, clear its cache and then restart to allow usage of the new certificate.
Posted May 02, 2022 - 19:36 PDT
Update
We are still determining the solution for resolving the link certificate errors shown with Google Chrome on some versions. Updates will be given within the next two hours or as soon as more significant updates are available.
Posted May 02, 2022 - 19:15 PDT
Identified
Our team identified the root cause of the certificate errors when attempting to resolve SendGrid links with Google Chrome browser. At this time, we are working towards implementing a solution to allow links to properly resolve. Another update will be provided in one hour or when a substantial update is available.
Posted May 02, 2022 - 18:05 PDT
Investigating
Starting around 5:10 PM PT on May 2, 2022 our engineers began investigating an issue involving the validity of link certificates for SendGrid links. Customer may see errors when clicking on links when using Google Chrome. This does not impact mail send. As a workaround, please try opening the link in a different web browser. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 02, 2022 - 17:22 PDT