Encountering errors while attempting to create a support ticket via the SendGrid portal

Incident Report for SendGrid

Monitoring

Our engineers have identified the problem and implemented a fix and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available
Posted Dec 04, 2025 - 21:23 PST

Investigating

Starting around 8.30 PM PST on Dec 4, our engineers began investigating an issue with our support portal. Customers may experience issues in submitting a ticket. We will provide another update in an hour or as soon as more information becomes available
Posted Dec 04, 2025 - 20:53 PST
This incident affects: Website.