Technical Incident: Expert Services Billing Page Unavailable
Incident Report for SendGrid
Resolved
Our team has identified the root cause and resolved the issue. Users can now view and purchase Expert Services on the billing page. We apologize about any inconvenience this may have caused. If you have any questions, please reach out to the Support team at https://support.sendgrid.com.
Posted 3 months ago. May 23, 2019 - 11:22 PDT
Investigating
We are currently experiencing an issue with the Expert Services section of the billing page. Users are unable to purchase or view pricing for Expert Services including Expert Insights, Email Implementation, and Email Bootcamp. Our team is investigating the issue. We will post updates as we learn more. Thank you for your patience. If you have questions, you can reach out to the Support team at https://support.sendgrid.com.
Posted 3 months ago. May 23, 2019 - 10:55 PDT
This incident affected: Website.