Some users were not properly downgraded On Dec 1st
Incident Report for SendGrid
Resolved
Our engineers are working on the complete fix for invoices. Some affected accounts will now see the right balance in the account. The fix should be applied to all the remaining affected accounts in the next week and will be reflected in the user interface under the billing page. Thank you for your continued patience.
Posted Dec 10, 2021 - 09:01 PST
Update
Our engineers continue working to fully resolve the billing issue with invoices, which was a result of the wrong plan applied at the beginning of the month. The team will continue to monitor the accounts affected. We will provide another update in 24 hours, or as soon as more information becomes available.
Posted Dec 09, 2021 - 13:46 PST
Update
Our engineers continue working to fully resolve the billing issue with invoices, which was a result of the wrong plan applied at the beginning of the month. The team will continue to monitor the accounts affected. We will provide another update in 24 hours, or as soon as more information becomes available.
Posted Dec 08, 2021 - 08:50 PST
Monitoring
Our engineers have mitigated the issue, and the accounts affected by the downgrade issue should now see the right plan associated to the account. The team still needs a couple of days to fully resolve the billing issue with invoices, which was a result of the wrong plan applied at the beginning of the month. The team will continue to monitor the accounts affected. We will provide another update in 24 hours, or as soon as more information becomes available.
Posted Dec 07, 2021 - 08:43 PST
Update
Engineers are continuing to work on a fix for the accounts affected by this downgrade issue. Due to the nature of the root cause identified, it will take until tomorrow, Dec 7th for the fix to be completely reviewed before it can be applied to the accounts.
All the affected accounts should now see the correct package, but the invoices are still not considered fixed.

We will provide an update in the next 24 hours or as soon as we have any additional information.
Posted Dec 06, 2021 - 12:50 PST
Update
Engineers are continuing to work on a fix for the accounts affected by this downgrade issue. Due to the nature of the root cause identified, it will take until tomorrow, Dec 7th for the fix to be completely reviewed before it can be applied to the accounts.
All the affected accounts should now see the correct package, but the invoices are still not considered fixed.

We will provide an update in the next 24 hours or as soon as we have any additional information.
Posted Dec 06, 2021 - 12:42 PST
Update
We are continuing to work on a fix for the affected accounts. We will provide an update in an hour or as soon as we have any additional information.
Posted Dec 06, 2021 - 11:43 PST
Identified
Our engineers have identified the issue that caused the accounts not to be downgraded properly on Dec 1st and are working towards a fix on the affected accounts. We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 06, 2021 - 10:53 PST
Investigating
On December 6th at 8:00 am PT our engineers noticed that some accounts were not downgraded correctly on Dec 1st. Our engineers are working on identifying the root cause of the issue.

We will provide an update in an hour or as soon as we have any additional information.
Posted Dec 06, 2021 - 09:55 PST
This incident affected: Billing.