Service Disruption - Inability to Sign Up or Upgrade Accounts
Incident Report for SendGrid
Resolved
The issue with paid account signups and upgrades has been resolved. We greatly appreciate your patience and apologize for any inconvenience this may have caused. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted Jun 03, 2020 - 20:02 PDT
Monitoring
Our team has identified the source of the issue and implemented a fix. We are continuing to monitor the situation and will provide an update when we confirm the issue has been resolved. We appreciate your patience and apologize for any inconvenience this may be causing. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted Jun 03, 2020 - 19:26 PDT
Investigating
Our team is investigating reports of the inability to sign up for paid plans or upgrade accounts starting around 11:20am MT. We’ll provide updates here as we have them. We apologize for the inconvenience this may have caused and thank you for your patience. If you have any questions, please contact our Support team at https://support.sendgrid.com/
Posted Jun 03, 2020 - 17:04 PDT
This incident affected: Website.