SendGrid engineers monitoring the environment have seen no further timeout errors in the logs. As a result this incident is being resolved at 1:03pst.
Posted Nov 04, 2024 - 13:04 PST
Monitoring
SendGrid engineers have found the cause and implemented a permanent fix for the timeout errors, and are now monitoring to ensure that everything is working and that timeouts do not begin to occur again.
We will follow up with an update in one hour or sooner if we have new information.
Posted Nov 04, 2024 - 12:23 PST
Update
SendGrid engineers are continuing to investigate the issue and explore a permanent fix for the timeouts. The issue is still mitigated for new users with a temporary fix. We will follow up with more information in one hour or as soon as we have another update.
Posted Nov 04, 2024 - 11:36 PST
Update
SendGrid engineers have found a temporary fix, and the issue is currently mitigated for users and any new attempts to login. We are continuing to investigate the root cause and work towards a solution. We we follow up in 1 hour or sooner if we have more information.
Posted Nov 04, 2024 - 10:35 PST
Investigating
Beginning around 7:30am PST SendGrid engineers noticed intermittent timeouts for some users when trying to login to the SendGrid console or UI. There is no impact to mail send, and the API is available as a workaround. If you experience a timeout error, you may also be able to successfully login on future attempts. We are still investigating, and will follow up in 1 hour or sooner if we have more information.