Shared IP Network Blocked by Spamhaus
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with the Shared IP Pools causing blocks for some Free, Essentials, or Basic plans customers has been resolved. All services are now operating normally at this time.
Posted Jul 20, 2022 - 12:51 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 20, 2022 - 12:21 PDT
Update
We are continuing to work towards a fix for this issue. We will provide another update within two hours or sooner if more information becomes available.
Posted Jul 20, 2022 - 10:25 PDT
Update
We are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Jul 20, 2022 - 09:22 PDT
Update
We are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Jul 20, 2022 - 08:23 PDT
Update
We are continuing to work towards a fix for this issue. We will provide another update within an hour or sooner if more information becomes available.
Posted Jul 20, 2022 - 07:24 PDT
Identified
Our engineers have identified the issue with email delivery on our shared IP address pools. They have taken the required actions. We'll provide an update in 1 hour or as soon as more information is available.
Posted Jul 20, 2022 - 06:23 PDT
Investigating
Starting around 09:00 am PST on 19th July, 2022, our engineers noticed an issue with the email delivery on our shared IP addresses and are currently investigating. Customers may experience an increase in blocks when sending emails. This will only impact customers on Free, Essentials, or Basic plans using shared IP pools. This does not impact customers using a dedicated IP. We will provide another update in an hour or as soon as more information becomes available.
Posted Jul 20, 2022 - 05:33 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns) and Mail Sending (API v3, SMTP).