Incident - Stats Delay
Incident Report for SendGrid
Resolved
Our engineers have validated that the issue has been resolved and Stats have been confirmed to be fully dequeued with no signs further delays. We sincerely apologize for the inconvenience and thank you for your patience.
Posted Aug 24, 2020 - 22:51 PDT
Update
Our engineers have confirmed that stats have been dequeued and customers should no longer be experiencing a delay. We are continuing to monitor the situation and will provide updates as they become available.
Posted Aug 24, 2020 - 21:53 PDT
Update
We are continuing to monitor our systems' performance and will continue to provide updates. We appreciate your patience.
Posted Aug 24, 2020 - 21:25 PDT
Update
We are continuing to monitor our systems' performance and will continue to provide updates. We appreciate your patience.
Posted Aug 24, 2020 - 20:44 PDT
Monitoring
Our engineers have implemented a fix and are now monitoring its performance. We will continue to provide updates as stats are dequeueing. We appreciate your patience.
Posted Aug 24, 2020 - 19:23 PDT
Update
Our engineers are continuing their work towards a resolution. Thank you for your continued patience.
Posted Aug 24, 2020 - 18:58 PDT
Update
At this time our engineers are continuing their work towards a resolution. Thank you for your continued patience.
Posted Aug 24, 2020 - 18:32 PDT
Identified
Our engineering team has identified the issue and is working towards a fix. At this time, a subset of customers may experience a delay in Global Stats. Thank you for your patience.
Posted Aug 24, 2020 - 17:57 PDT
Investigating
Starting around 5.00pm MT, our engineers determined that a subset of customers may notice a delay in mail send and engagement related stat events. Mail send is not impacted. Our engineers are investigating the situation. We apologize for any inconvenience this may cause.
Posted Aug 24, 2020 - 17:23 PDT
This incident affected: Other Services (API) and Website.