Service Disruption: Sender Authentication Delays
Incident Report for SendGrid
Resolved
We have confirmed that the issue has been resolved. We thank you for your patience and apologize for any inconvenience this may have caused.
Posted Nov 02, 2020 - 15:17 PST
Update
Our third party provider reports their incident is resolved. Our engineers have confirmed that requests have been dequeued and users should no longer be experiencing issues. We are monitoring our systems and will provide an update when we confirm the issue has been fully resolved. We appreciate your patience
Posted Nov 02, 2020 - 14:58 PST
Update
Our third party service provider has now implemented a fix and are monitoring their systems. We will continue to provide updates as sender authentication requests are being dequeued. We appreciate your patience.
Posted Nov 02, 2020 - 13:38 PST
Update
We are continuing to monitor as our third party works towards implementing a fix. We sincerely apologize for the inconvenience and thank you for your patience.
Posted Nov 02, 2020 - 12:48 PST
Update
We are continuing to monitor as our third party works towards implementing a fix. We sincerely apologize for the inconvenience and thank you for your patience.
Posted Nov 02, 2020 - 11:16 PST
Update
Our engineers have determined that users may also experience delays in Sender Authentication validation requests. These requests are being queued and will be dequeued once the issue is resolved. We are closely monitoring the situation. We appreciate your patience and will provide updates as they become available.
Posted Nov 02, 2020 - 10:01 PST
Update
Our engineers are still monitoring the situation and we will provide updates as they become available. We appreciate your patience and apologize for any inconvenience this may be causing.
Posted Nov 02, 2020 - 08:41 PST
Monitoring
Around 7am MT, a third party service declared an outage that is impacting our SPF, DKIM, and MX records. Users who are attempting to complete Sender Authentication on their account may be unable to complete the process and/or validate their domain. Our engineers are monitoring the situation and will provide updates as they become available.
Posted Nov 02, 2020 - 07:48 PST
This incident affected: Other Services (API) and Website.