Customers May Not Receive Password Reset Email
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue with password reset emails has been resolved. All services are now operating normally at this time.
Posted Mar 16, 2023 - 11:15 PDT
Monitoring
Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 16, 2023 - 10:47 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 16, 2023 - 10:36 PDT
Update
Our engineers are continuing to investigate this issue. Customers may still not receive their password reset email when resetting their password. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 16, 2023 - 10:22 PDT
Investigating
Starting around 9:03 AM PT on March 16th, 2023, our engineers began investigating an issue with customer's not receiving their password reset email. Users may not receive their password reset email when resetting their password. This does not impact mail send. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 16, 2023 - 09:18 PDT
This incident affected: Website.