Technical Incident - New Marketing Campaigns sends paused while investigating contact display issue
Incident Report for SendGrid
Resolved
After monitoring the fix, we have verified that the issue is resolved. Sending via Single Sends and automation has been re-enabled and New Marketing Campaigns contact data is largely up-to-date. There may still be a very small subset of customers who are experiencing contact delays related to imports/updates performed during this outage. Our team will be addressing these delays this morning, however affected customers can perform their imports/updates again should they find they are not seeing contact related additions/changes performed during the outage. We apologize for any inconvenience this caused and appreciate your patience. Please reach out to our Support team at https://support.sendgrid.com if you have any questions.
Posted Apr 21, 2020 - 05:50 PDT
Monitoring
Our team has identified and mitigated the issue. Sending via Single Sends and Automation has been re-enabled and the contact issue has been resolved. A very small subset of customers may find that their contact imports/updates are still delayed. We are monitoring system performance at this time and working to clear the delayed contact data. We'll provide an update when this is complete. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 21, 2020 - 04:45 PDT
Update
Our team is currently implementing a fix. New sending via Single Sends and Automation continues to remain paused. We will provide additional updates as new information becomes available. We apologize for any inconvenience caused and thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 21, 2020 - 00:03 PDT
Update
Our team is currently implementing a fix. New sending via Single Sends and Automation continues to remain paused. Our next update will be in two hours or when we have new information. We apologize for any inconvenience caused and thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 20, 2020 - 21:00 PDT
Update
We are still working on implementing a fix. New sending via Single Sends and Automation will continue to remain paused. Additionally, customers may still not see contact imports and updates reflected properly in the UI. Our next update will be in two hours or when we have new information. We apologize for any inconvenience caused and thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 20, 2020 - 18:03 PDT
Update
Our team continues to work towards implementing a fix. New sending via Single Sends and Automation will continue to remain paused. Our next update will be in two hours or when we have new information. We apologize for any inconvenience caused and thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 20, 2020 - 15:57 PDT
Identified
Our team has identified the issue and is working on implementing a fix. Sending via New Marketing Campaigns Single Sends and Automation will continue to remain in a paused state to avoid sending to partial lists/segments. We will continue to provide updates as we have new information. Thank you for your patience. Please contact our support team with any questions: https://support.sendgrid.com/.
Posted Apr 20, 2020 - 13:07 PDT
Investigating
Our engineers have paused sending on New Marketing Campaigns Single Sends and Automations while we investigate contact display issues for a subset of customers. These customers may not see contact updates reflected on the Contacts page. Legacy Marketing Campaigns contacts and sends are not affected. We will provide additional updates as they become available and greatly appreciate your patience. Please contact our Support team with any questions: https://support.sendgrid.com/.
Posted Apr 20, 2020 - 11:34 PDT
This incident affected: Marketing Campaigns (Marketing Campaigns).