Login Issue Cloudflare CAPTCHA Failing to Load

Incident Report for SendGrid

Identified

Our engineers are continuing to investigate the issue. We will provide another update in hour or as soon as more information becomes available.
Posted Mar 18, 2026 - 12:35 PDT

Investigating

Starting around 11:06 AM PST on March 18, 2026, our engineers began investigating an issue with Cloudflare CAPTCHA failing to load on SendGrid and Twilio login pages. Customers may experience difficulty accessing the user console, as the failing CAPTCHA prevents successful login. This does not impact mail send. We will provide another update in an hour or as soon as more information becomes available.
Posted Mar 18, 2026 - 11:33 PDT
This incident affects: Website.