Subuser Management Page not Displaying Request Totals
Incident Report for SendGrid
Resolved
This incident has been resolved, and systems are operating normally at this time.
Posted Jan 27, 2022 - 09:08 PST
Update
We are continuing to monitor the fix implemented at this time. We will provide more updates as they become available.
Posted Jan 26, 2022 - 18:49 PST
Monitoring
A fix has been implemented, and we are monitoring system performance. We will provide more details in about an hour, or as soon as more information becomes available.
Posted Jan 26, 2022 - 17:30 PST
Update
A solution has been identified, and engineers are finalizing a plan to implement. We will provide another update in about an hour from now, or as soon as more information becomes available.
Posted Jan 26, 2022 - 15:50 PST
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in about an hour or as soon as more information becomes available.
Posted Jan 26, 2022 - 14:57 PST
Update
We are continuing to investigate this issue and will provide more information in the next hour, or as soon as more information becomes available.
Posted Jan 26, 2022 - 13:59 PST
Investigating
On January 26 at about 12:35PT, our team began investigating an issue where a subset of accounts are displaying a count of "0" (zero) for request totals for the month within the Subuser Management page.

Customers experiencing this issue may notice that under the "Subuser Management" setting, zero requests are being displayed for subuser accounts that have been known to successfully send requests during the month.

Customers using GET `https://api.sendgrid.com/v3/subusers/{subuser_name}/monitor` will receive a 404 response at this time

There is no impact to mail send.

We will provide more updates in the next hour, or as more information becomes available.
Posted Jan 26, 2022 - 13:01 PST
This incident affected: API and Website.