Unable to use test feature in Legacy Campaigns

Incident Report for SendGrid

Resolved

Our engineers have monitored the fix and confirmed the issue with test feature has been resolved. All services are now operating normally at this time.
Posted Apr 17, 2024 - 22:58 PDT

Monitoring

Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Apr 17, 2024 - 22:36 PDT

Identified

We have identified the primary cause, taken remediating action and are beginning to see recovery from this incident. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 17, 2024 - 21:26 PDT

Investigating

Starting around 12:20 AM UTC on 18th April 2024, our engineers have began investigating an issue with test feature in Legacy Campaigns. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 17, 2024 - 21:02 PDT