Unable to login to SendGrid UI
Incident Report for SendGrid
Resolved
Our engineers have monitored the issue and confirmed that logins are now functioning as expected.
Posted Jul 18, 2023 - 11:25 PDT
Monitoring
As of 10:15 PT, July 18, logins appear to be functioning normally. Our engineers will be monitoring the issue to ensure logins remain functional.
Posted Jul 18, 2023 - 10:25 PDT
Investigating
Beginning at 10:05 AM PT on July 18, our engineers began investigating an issue with customer logins to the SendGrid UI. Customers may see an error when attempting to login to their SendGrid dashboard after entering their 2FA code. We will provide another update within an hour or as soon as more information becomes available.
Posted Jul 18, 2023 - 10:10 PDT
This incident affected: Website.