Images uploaded to Legacy are not loading anymore
Incident Report for SendGrid
Resolved
Our engineers have monitored the current issue with Legacy Design Editor, they have deployed to determine a workaround, users must re-upload their images have to their legacy libraries. All services should operate normally by performing this change.
Posted Dec 20, 2022 - 10:25 PST
Monitoring
Upon further investigation, our engineering team determined that on December 19, 2022, a new change to the host of the Legacy Editor was made that resulted in these issues.

We changed our host from AWS to CloudFront.

Our engineers recommended re-uploading their images so they can be assigned to the new URL containing the CloudFront Host. Also, recommending to update their payloads so the links used are the CloudFront ones instead of the AWS.

This did not impact Marketing campaigns.

This did not impact mail send.

Our team will monitor the reverted changes for the next 30 minutes or provide further information as it becomes available.
Posted Dec 20, 2022 - 07:18 PST
Investigating
Starting around 9:00 on Monday 19th, 2022, our engineers began investigating an issue with Legacy Design Editor. Customer may experience their images not being loaded when using Legacy editor, the error shows: "This XML file does not appear to have any style information associated with it. The document tree is shown below.". This is only affecting Legacy customers.

This doesn't affect Marketing campaigns.

This doesn't impact mail send.

We will provide another update in an hour or as soon as more information becomes available.
Posted Dec 20, 2022 - 06:23 PST
This incident affected: Marketing Campaigns (Marketing Campaigns).