SendGrid Event Delays for EU Regions
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted Nov 16, 2024 - 15:54 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2024 - 15:37 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2024 - 15:06 PST
Investigating
Starting around 1:00 PM PST on Saturday, November 16th, 2024, our Engineers began investigating an issue with SendGrid Events. Customers may experience delays with Event reporting associated to mail send. The issue is causing intermittent errors and delays on Events (webhook, open and click events, Stats and Email Activity Feed events). This does not impact mail send. We are actively working to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 16, 2024 - 14:34 PST
This incident affected: Webhooks (Event Webhook) and Statistics, Email Activity.