Mail Send Delays
Incident Report for SendGrid
Resolved
Our engineers have monitored the fix and confirmed the issue has been resolved. Emails that were delayed earlier should start getting delivered. All services are now operating normally at this time.
Posted Oct 11, 2022 - 22:17 PDT
Update
A fix is currently being implemented by our engineers. We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 11, 2022 - 21:30 PDT
Update
Our engineers are still working on a fix. However there should not be any mail delays moving forward. We will provide another update in an hour or as soon as more information becomes available.
Posted Oct 11, 2022 - 20:37 PDT
Identified
Our engineers have identified the issue and are working toward a fix. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 11, 2022 - 19:35 PDT
Investigating
Starting around 6:02pm PT on Tuesday October 11th, 2022, our engineers began investigating an issue with mail send delays and some stats delays. Users may experience delays for mail sent around this time and stats delays. This does impact mail sent around 6:02pm PT but all new mail should not be affected. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 11, 2022 - 18:37 PDT
This incident affected: Mail Sending (API v3, SMTP, API v2), Marketing Campaigns (Marketing Campaigns), and Statistics.