Important Security Updates to Your Account - Password Reset Instructions
Incident Report for SendGrid
Resolved
This incident has been resolved.
Posted about 4 years ago. May 15, 2015 - 19:21 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 4 years ago. Apr 27, 2015 - 11:56 PDT
Investigating
Important Security Updates to Your Account - Password Reset Instructions

For more information on the security incident see the blog - visit here

At SendGrid we view the security of our email platform and our customers with the highest priority. Based on a recent security incident, we’re asking you today to take some precautionary yet very important steps to improve the security of your SendGrid account.

Please reset your SendGrid account passwords today. Please note that in order to maintain seamless email flow, it is important to also update any custom code, web pages or servers that use this account with your new passwords. If you are uncertain about these additional steps, consult the email administrator who created the account. For tips on how to reset your password with minimal impact to your integrations read here.

Need help to complete the security update? Here are a list of resources that can help. Choose only the option that is most helpful - you do not need to do all of them.

Option 1: Log in to your account at sendgrid.com (How to steps visit here. Short video visit here)
Option 2: Request password reset link at sendgrid.com (Also shown in links for option 1)
Option 3: Use API calls (How to steps visit here)
Option 4: If you have an account through one of our reseller partners, look for specific communication from that partner. Many partners like Heroku, Appdirect, Engineyard and Softlayer will make the update seamlessly on your behalf.

Are you done with this security update? Most customers will only have the main credential to reset but if your account configuration is more complex or you are uncertain you can review these additional items.

Have you changed the main account credential? Complete any of the options listed above.

Have you checked for subuser accounts and, if present, updated their credentials? (If you have a Silver package or higher, you can check subusers under Subuser Management on your Account Overview page)

Have you checked for multiple user credentials and if present updated their credentials? (For tips on managing multiple user credentials visit here.)

Are you having problem accessing the email address associated to your SendGrid Account? (This KB article has suggestions visit here.)

Are you having problems finding your username? (This KB article has suggestions visit here)

Do you have a reseller account? Look for specific communication from your reseller. Many partners like Heroku, Appdirect, Engineyard, Softlayer, and Azure will complete this update with no action required from you.

Have you checked to see if your account utilizes a custom DKIM and if present, updated it at SendGrid and your DNS host. (This KB article has suggestions visit here)

NOTE: We require passwords to be a minimum of 8 alpha-numeric characters. Make sure any new passwords you set conform to this requirement.

Thanks for your cooperation on this and as always, please reach out to us at support@sendgrid.com with any questions.
Posted about 4 years ago. Apr 27, 2015 - 11:30 PDT