Failure To Deliver Some Processed Messages
Incident Report for SendGrid
Resolved
Our engineers have confirmed the issue with mail delays has been resolved. All services are now operating normally at this time. Our team will continue to investigate this issue and gather additional details.
Posted Oct 05, 2022 - 10:22 PDT
Update
Our engineers have implemented a fix and at this time there is no further impact. We are continuing to monitor system performance and we are currently working with our teams to gather as much information as possible. We will provide another update as soon as more information becomes available.
Posted Oct 05, 2022 - 09:37 PDT
Monitoring
Our engineers identified the problem and implemented a mitigation, but unfortunately, some of the delayed emails were lost during the process and could not be resent. Customers affected may notice that emails expected to be sent were processed or deferred but no further information about the status of the emails will be available.
Posted Oct 03, 2022 - 23:42 PDT
Update
Our team is still continuing to investigate this issue. We will provide more updates on the same, once available.
Posted Oct 03, 2022 - 21:01 PDT
Update
Our team is continuing to investigate this issue. We will provide more updates in about the next hour, or as soon as they may become available.
Posted Oct 03, 2022 - 18:48 PDT
Update
Our engineers are continuing to investigate this issue. Affected users may continue to see delays in mail processing. All new mail requests should process normally for all users at this time.
Posted Oct 03, 2022 - 17:49 PDT
Investigating
Starting around 4:25 PM PT on October 3, our engineers began investigating an issue relating to mail processing. Affected users may experience delays in mail processing time, and some mail may be delayed. As of the time of this posting, no new outgoing mail should be impacted. We will provide another update in about an hour, or as soon as more information becomes available
Posted Oct 03, 2022 - 16:50 PDT
This incident affected: Mail Sending (API v3, SMTP).